تبلیغات
آموزش CCNA ,آموزش CCNP ,آموزش CCIE ,آموزش CCDA ,آموزش CCDP ,آموزش CCDE ,آموزش CCSP ,آموزش CCIP ,آموزش CCVP ,آموزش سیسکو ,آموزش CISCO ,آموزش سیسکو مقدماتی ,آموزش سیسکو پیشرفته و حرفه ای ,فیلم آموزش CCNA ,فیلم آموزش CCNP ,فیلم آموزش CCIE ,فیلم آموزش CCDA ,ف
 
 
 
آموزش CCNA ,آموزش CCNP ,آموزش CCIE ,آموزش CCDA ,آموزش CCDP ,آموزش CCDE ,آموزش CCSP ,آموزش CCIP ,آموزش CCVP ,آموزش سیسکو ,آموزش

آموزش Cisco Access List|دانلود مقاله آموزشی سیسکو |

نویسنده : علی صالحی | تاریخ : 12:38 ب.ظ - دوشنبه 18 اردیبهشت 1391

آموزش Cisco Access List





Cisco Access List در ترجمه لغوی به معنای لیست دسترسی سیسکو می باشد که زیاد هم از معنای واقعی خود دور نیست.
همانطور که از اسم آن بر می آید به وسیله این ابزار میتوانیم بر روی سخت افزارهای سیسکو فایروال ایجاد کنیم.
از آنجا که بحث فایروال بسیار گسترده است و تنها به یک   access list  منتهی نمیشود به این نوع فایروال packet filter گفته میشود.

 
Cisco Access List در ترجمه لغوی به معنای لیست دسترسی سیسکو می باشد که زیاد هم از معنای واقعی خود دور نیست.
همانطور که از اسم آن بر می آید به وسیله این ابزار میتوانیم بر روی سخت افزارهای سیسکو فایروال ایجاد کنیم.
از آنجا که بحث فایروال بسیار گسترده است و تنها به یک   access list  منتهی نمیشود به این نوع فایروال packet filter گفته میشود.
حتما خوانندگان عزیز سیسکو را شناخته و از کارایی آن خبر دارند.

از آنجا که ورودی اینترنت 80 درصد شبکه هایی که ما با آنها کار می کنیم Cisco هست میتوانیم با بکار گیری Access list در آنها امنیت زیادی را برای خود به ارمغان بیاوریم. نا گفته نماند که مهمترین گزینه در Packet filter ها کانفیگ خوب آنهاست نه Brand یا مدل دستگاه. شما اگر با اصول Packet Filtering آشنایی داشته باشید بر روی هر سیستم عامل یا سخت افزاری تنها با آموختن Syntax آن میتوانید یک فایروال ایجاد کنید.

من در اینجا به توضیح قوائد آن در سیسکو میپردازم.

برای ایجاد access list شما نیاز به IOS های بالاتر از ورژن 8.3 دارید.

دو مرحله برای ایجاد یک access list داریم. اول میبایست ACL مربوطه را نوشته و دوم آن را به یک اینترفیس اعمال کنیم.
بدیهیست در صورت عدم اعمال ACL به یک اینترفیس ACL مذکور بلا استفاده می ماند.

پر کاربردترین ACL ها IP Access list است. زیرا اکثر ترافیکها بر روی پروتکل IP انتقال می یابد.

خود IP access list دو نوع است. Standard و Extended

Standard تنها بر اساس SOURCE IP address می تواند کنترل کند.

Extended بر حسب SOURCE and DESTINATION IP address و SOURCE and DESTINATION Port می تواند محدودیت ایجاد کند.
معمولا برای نام گذاری access list ها از اعداد استفاده میشود. که از شماره 1 تا 99 برای Standard و 100 تا 199   برای Extended استفاده میشود. البته اعداد 1300  تا 1999 برای Standard و 2000 تا 2699 برای Extended  رزرو شده اند.

قائده یک  Standard Access list بدین صورت است:

access-list access-list-number {permit|deny} {host|source source-wildcard|any}
یعنی در ابتدا میبایست عبارت access-list را تایپ نموده سپس یک شماره به آن اختصاص میدهیم و در آخر وظیفه آن که نابودی یا اجازه عبور یک پکت هست را مشخص میکنیم.

در مثال زیر میخواهیم تنها به یک رنج IP اجازه عبور از اینترفیس Ethernet0 را بدهیم.

ابتدا access list مورد نظر را می نویسیم
access-list 10 permit 192.168.20.0    0.0.0.255
access-list 10 deny any


سپس به یک اینترفیس اعمال میکنیم
interface ethernet0
ip access-group 10 in
exit

Extended access list ها را وقتی به کار میگیریم که نیاز به انعطاف بیشتری داریم. مثلا وقتی نیاز به فیلتر یک پورت خاص است.
قائده آن بدین صورت است:

access-list access-list-number {deny|permit} protocol source source-wildcard destination destination-wildcard [precedence precedence][tostos][log]

پس از عبارت access-list میبایست شماره آن را از همان رنج ذکر شده انتخاب کنیم .سپس action آن را که حذف یا عبور packet است را انتخاب کرده و آدرس مقصد و مبدا و همچنین پروتکل یا پورت آن را مشخص میکنیم.
برای نوشتن پروتکل ما مجاز به استفاده از پروتکل های زیر هستیم:

eigrp, gre, icmp, igmp, igrp, ip, ipinip, nos, ospf, tcp, or udp
همچنین می توان از یک keyword بین 0 تا 255 استفاده کرد که هر کدام بیانگر پروتکلی خاص است.
اگر ما عبارت ip را استفاده کنیم به عنوان تمامی پروتکل های IP شناخته میشود.
برای مشخص کردن هر آدرسی (any) نیز باید از عبارت 255.255.255.255 استفاده کرد.

Option های precedence و tos نیز دو ابزار اختیاریست که برای سرویس های خاص به کار می رود. که باید سرویس مورد نظر را با وارد کردن کد آن که precedence از 0 تا 7 و tos از 0 تا 15 مشخص شده اند را فعال کرد.
Log نیز یک ابزار اختیاری دیگر است که با فعال کردن آن میتوانیم از access list خود گزارش برداریم.

با مثالی بیشتر با Extended access list آشنا میشویم:


اجازه دسترسی سابنت 217.219.102.0/24 با آدرس 192.168.20.27 با هر پروتکلی

 access-list 105 permit ip 217.219.102.0   0.0.0.255   192.168.20.27   0.0.0.0

اجازه دسترسی آدرس 217.219.108.15 به سابنت 192.168.20.0/24 با هر پروتکلی

access-list 105 permit ip 217.219.108.15  0.0.0.0   192.168.20.0   0.0.0.255

اجازه دسترسی سابنت   10.0.0.0/24 به سابنت  172.22.18.0/24 تنها با پورت 23 (telnet)

access-list 105 permit tcp 10.0.0.0   0.255.255.255   172.22.18.0   0.0.0.255 eq 23

عدم اجازه دسترسی همه جا به همه جا روی پورت snmp که 161 است

access-list 105 permit udp any any eq 161

عدم اجازه پینگ (echo reply icmp type 0) از سابنت 172.12.0.0/16 به همه جا
access-list 105 deny icmp 172.12.0.0   0.0.255.255  any  0
عدم دسترسی کلیه packet های دیگر

access-list 105 deny ip any any
و در آخر اعمال آن به یک اینترفیس
interface serial0
ip access-group 105 out
exit
همانطور که میدانید ترتیب در access list ها مهم است.
به همین علت وقتی که لیست ACL ها را مشاهده میکنیم یک سری اعداد کنار آنها مینویسد که بیانگر اولویت آنهاست.
ما میتوانیم خود دستی آنها را وارد کنیم:

مثال 1: 
ACL ما بدین صورت است

Router#show access-list
Extended IP access list 101
    10 permit tcp any any
    20 permit udp any any
    30 permit icmp any any
حال میخواهیم در ابتدای آن یک خط اضافه کنیم

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#ip access-list extended 101
Router(config-ext-nacl)#5 deny tcp any any eq telnet
Router(config-ext-nacl)#exit
Router(config)#exit
Router#
هم اکنون بدین صورت می شود.

Router#show access-list
Extended IP access list 101
    5 deny tcp any any eq telnet
    10 permit tcp any any
    20 permit udp any any
    30 permit icmp any any
Router#
مثال 2:

قبلا یکبار به آن یک خط اضافه کرده ایم. برای بار دوم چنین عمل میکنیم

routerB#show access-lists
Extended IP access list 101
    10 permit tcp any any
    15 permit tcp any host 172.162.2.9
    20 permit udp host 172.16.1.21 any
    30 permit udp host 172.16.1.22 any

routerB#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
routerB(config)#ip access-list extended 101
routerB(config-ext-nacl)#18 per tcp any host 172.162.2.11
routerB(config-ext-nacl)#^Z

 ترتیب آن بدین صورت می شود:
routerB#show access-lists
Extended IP access list 101
    10 permit tcp any any
    15 permit tcp any host 172.162.2.9
    18 permit tcp any host 172.162.2.11
    20 permit udp host 172.16.1.21 any
    30 permit udp host 172.16.1.22 any
routerB#
نکته 1:
برای برداشتن یک access list میبایست همان ACL را تایپ نموده و در ابتدای سطر یک no قرار دهیم:

no access-list 105 deny ip any any
نکته2:
برای مشاهده ACL ها از دستور زیر استفاده میکنیم.

show access-list 


دسته بندی : مقاله های سیسکو|آموزش سیسکو|آموزش cisco|دانلود مقاله رایگان سیسکو .. تعداد مقاله های این بخش ,
 

آخرین مطالب

» سیسکو دو مدل‌ ارتقایافته از سوییچ‌های خود یکی از سری Director-class و دیگری Multiservice را معرفی کرد ( شنبه 13 مهر 1392 )
» آموزش CCDP,فیلم های آموزشی CCDP,ازمون سیسکو دوره CCDP,آزمون 642-871 سیسکو,فیلم های آموزشی CCDP ARCH_642-871 ( چهارشنبه 29 خرداد 1392 )
» آموزش CCNP Security VPN,فیلم های آموزشی CCNP Security VPN,آموزش CCNP-VPN فیلم های آموزشی ccnp vpn,آموزش 642-648,فیلم های آموزشی آزمون سیسکو دوره ccnp آزمون 642-648 ( یکشنبه 29 اردیبهشت 1392 )
» آموزش CCIE,فیلم های آموزشی CCIE,آموزش تصویری CCIE, آموزش CCIE-Practice.Lab.Video.Walkthrough آموزش,21ساعت آموزش CCIE ( سه شنبه 17 اردیبهشت 1392 )
» آموزش CCIE,فیلم های آموزشی CCIE,آموزش تصویری CCIE, آموزش CCIE-routering and switching آموزش,25ساعت آموزش CCIE ( سه شنبه 17 اردیبهشت 1392 )
» آموزش CCDA ,فیلم های آموزشی CCDA ,آموزش تصویری CCDA ,آموزش exam 640-863 آموزش,9 ساعت آموزش CCDA ( پنجشنبه 12 اردیبهشت 1392 )
» آموزش ccvp,فیلم های آموزشی ccvp,آموزش تصویری CCVP,آموزش exam 642-642 QOS آموزش,9 ساعت آموزش CCVP,آموزش CCVP 642-642 QOS Quality Of Service,آموزش QOS سیسکو ( پنجشنبه 12 اردیبهشت 1392 )
» آموزش CCSP,فیلم های آموزشی CCSP,آموزش تصویری CCSP,آموزش exam 642-524 آموزش,12 ساعت آموزش CCSP,آموزش SNAF Securing Networks With ASA Fundamentals,پکیج آموزش سیسکو آموزش CCSP ( پنجشنبه 12 اردیبهشت 1392 )
» آموزش CCSP,فیلم های آموزشی CCSP,آموزش تصویری CCSP,آموزش exam 642-504 آموزش,10 ساعت آموزش CCSP,آموزش SNRS Securing Networks With Cisco Routers And Switches,پکیج آموزش سیسکو آموزش CCSP ( پنجشنبه 12 اردیبهشت 1392 )
» آموزش ccvp,فیلم های آموزشی ccvp,آموزش تصویری CCVP,آموزش exam 642-444 cvoice آموزش,18 ساعت آموزش CCVP,آموزش 642-444 CIPT Cisco IP Telephony ( پنجشنبه 12 اردیبهشت 1392 )
» ios روترسیسکو,تمام ios های روتر سیسکو,بانک ios سیسکو,سیسکو ios ios سیسکو,سیسکو ios 1700 ios سیسکو,سیسکو ios 2610 ios سیسکو,سیسکو ios 2613 ios سیسکو,سیسکو ios 2610xm-2611xm ios سیسکو,سیسکو ios 2691 ios سیسکو,سیسکو ios 3620 ios سیسکو,سیسکو ios 3640 ios سیسکو,سیسکو ios 3660 ios سیسکو,سیسکو ios 7200 ios سیسکو,دانلود ios سیکسو ( یکشنبه 1 اردیبهشت 1392 )
» آموزش CWNE ,CWNE چیست؟,فیلم های آموزشی CWNE ,شبکه های بیسیم CWNE ,مدرک CWNE چیست,مقاله CWNE ,آموزش تصویری CWNE آموزش ,آموزش CCertified Wireless Network Expert ,آموزش شبکه های بی سیم ( سه شنبه 27 فروردین 1392 )
» آموزش CWAP ,CWAP چیست؟,فیلم های آموزشی CWAP ,شبکه های بیسیم CWAP ,مدرک CWAP چیست,مقاله CWAP ,آموزش تصویری CWAP آموزش ,آموزش Certified Wireless Analysis Professional ,آموزش شبکه های بی سیم ( سه شنبه 27 فروردین 1392 )
» آموزش CWDP ,CWDP چیست؟,فیلم های آموزشی CWDP ,شبکه های بیسیم CWDP ,مدرک CWDP چیست,مقاله CWDP ,آموزش تصویری CWDP آموزش ,آموزش Certified Wireless Design Professional,آموزش شبکه های بی سیم ( سه شنبه 27 فروردین 1392 )
» آموزش CWSP ,CWSP چیست؟,فیلم های آموزشی CWSP ,شبکه های بیسیم CWSP ,مدرک CWSP چیست,مقاله CWSP ,آموزش تصویری CWSP آموزش ,آموزش Certified Wireless Security Professional ,آموزش شبکه های بی سیم ( سه شنبه 27 فروردین 1392 )
» آموزش CWNA ,CWNA چیست؟,فیلم های آموزشی CWNA ,شبکه های بیسیم CWNA ,مدرک CWNA چیست,مقاله CWNA ,آموزش تصویری CWNA آموزش ,آموزش Certified Wireless Network Administrator,آموزش شبکه های بی سیم ( سه شنبه 27 فروردین 1392 )
» آموزش CWTS ,CWTS چیست؟,فیلم های آموزشی CWTS ,شبکه های بیسیم CWTS ,مدرک CWTS چیست,مقاله CWTS ,آموزش تصویری CWTS آموزش ,آموزش Certified Wireless Technology Specialist,آموزش شبکه های بی سیم ( سه شنبه 27 فروردین 1392 )
» آموزش پروتکل pop3 آموزش ,آیا میدانید پروتکل pop3 چیست,اطلاعات کامل در مورد پروتکل pop3 و imap, پروتکل pop3 توضیح,نحوه ی عملکرد پروتکل pop3,درباره pop3,آموزش پروتکل IMAP آمورش ,آیا میدانید پروتکل IMAP چیست, پروتکل IMAP چیست,نحوه ی عملکرد پروتکل IMAP ,درباره پروتکل IMAP ( دوشنبه 26 فروردین 1392 )
» آموزش پروتکل MIME ,آیا می دانید پروتکل MIME چیست؟, پروتکل MIME چیست؟,پروتكل ترکیبی چیست؟,پروتکل MIME ,درباره پروتکل MIME ( دوشنبه 26 فروردین 1392 )
» آموزش پروتکل H323 ,آیا می دانید پروتکل H323 چیست؟, پروتکل H323 چیست؟,پروتكل ترکیبی چیست؟,پروتکل H323 ,درباره پروتکل H323,پروتکل H245 چیست؟,پروتکل H225RAS چیست؟,پروتکل RTCP چیست ؟,پروتکل H225 چیست؟ ( دوشنبه 26 فروردین 1392 )
» آموزش پروتکل RDP ,آیا می دانید پروتکل RDP چیست؟, پروتکل RDP چیست؟,پروتكل ارتباط از راه دور چیست؟,پروتکل RDP ,درباره پروتکل RDP,آموزش تغییر شماره پورت Remote Desktop ,آموزش کامل Remote Desktop,آموزش کامل ریموت دسکتاپ ( دوشنبه 26 فروردین 1392 )
» آموزش پروتکل SMTP ,آیا می دانید پروتکل SMTP چیست؟, پروتکل SMTP چیست؟,پروتكل انتقال پست الكترونیكی چیست؟,پروتکل SMTP ,درباره پروتکل SMTP,پروتکل ارسال ایمیل گروهی ( دوشنبه 26 فروردین 1392 )
» آموزش پروتکل SNMP ,آیا می دانید پروتکل SNMP چیست؟, پروتکل SNMP چیست؟,پروتکل مدیریت شبکه چیست؟,پروتکل SNMP ,درباره پروتکل SNMP ( دوشنبه 26 فروردین 1392 )
» آموزش پروتکل SOAP,آیا می دانید پروتکل SOAP چیست؟, پروتکل SOAP چیست؟,پروتکل دسترسی آسان به اشیاء چیست؟,پروتکل SOAP ,درباره پروتکل SOAP,پروتکل مربوط و مبتنی بر xml,پروتکل Simple Object Access Protocol - SOAP چیست ( دوشنبه 26 فروردین 1392 )
» آموزش پروتکل SSH,آیا میدانید پروتکل SSHچیست؟, پروتکل SSHچیست؟,پوسته امن چیست؟,پروتکل SSH,درباره پروتکل SSH,دربارهSSH1 یا SSH-1 و SSH2 یا SSH-2,پروتکل پوسته امن,پروتکل Secure Shell چیست ( دوشنبه 26 فروردین 1392 )
» آموزش پروتکل Telnet,آیا میدانید پروتکل Telnet چیست؟, پروتکل Telnet چیست؟,تِل‌نت چیست؟,پروتکل Telnet ,درباره پروتکل Telnet ,درباره Telnet 5250, ( دوشنبه 26 فروردین 1392 )
» آموزش پروتکل TLS/SSLپروتکل امنیت لایه انتقال,آیا میدانید پروتکل امنیت لایه انتقال چیست؟, پروتکل TLS/SSL چیست؟,لایهٔ سوکت‌های امن,اس‌اس‌ال چیست؟,پروتکل TLS,درباره پروتکل ssl ( دوشنبه 26 فروردین 1392 )
» آموزش VLAN Trunking Protocol آموزش,آموزش vtp آموزش ,آموزش Trunking آموزش ,دستورات Trunking ,فرامین Trunking ,کانفیگ Trunking,دستورات vtp ,فرامین vtp ,کانفیگ vtp ( دوشنبه 26 فروردین 1392 )
» آموزش ccna آموزش ,فیلم های آموزشی ccna cisco ( یکشنبه 27 اسفند 1391 )
» ایجاد Vlan در سوئیچ های Cisco,آموزش زدن vlan در سوئیچ,آموزش vlan بندی در سیسکو,آموزش فرامین vlan در سوئیچ سیسکو, شبکه فهرست مطالب در مورد نویسنده اساتید محترم پیوندهای مفید ۱) ایجاد Vlan در سوئیچ های Cisco, تعریف وی لن در سوئیچ,ایجاد وی لن در سیسکو,اختصاص پورت به Vlan,نمایش وضعیت Vlan ها, ( شنبه 19 اسفند 1391 )
 
 

آموزش ارتباط به سویچ سیسکو آموزش CCIE-Practice.Lab.Video.Walkthrough آموزش فیلم های آموزشی CCDP آموزش CCDE آموزش تصویری تنظیمات اتصال به سویچ سیسکو دانلود فیلم آموزشی CCIE دانلود 25ساعت آموزش CCIE آموزش cisco آزمون 642-871 سیسکو آموزش CCDP آموزش Plugging into the PKI آموزش فیلم های آموزشی CCDP ARCH_642-871 آموزش تصویری CCVP خرید پستی آموزش سیسکو خرید پستی آموزش CCIE خرید پستی آموزش سیسکو آموزش CCIE ازمون سیسکو دوره CCDP دانلود فیلم آموزشی سیسکو CCIE آموزش SSL and IPsec Technologies آموزش فیلم های آموزشی سیسکو cisco دانلود مقاله کامل آموزش اتصال به یک Cisco Switch و پیکربندی آن آموزش CCIE-routering and switching آموزش خرید پستی سیسکو آموزش CCNA آموزش CCNP فیلم های آموزشی ccvp آموزش Virtual Private Networks (VPNs) Gettin آموزش آموزش پروتکل IMAP آمورش سیسکو دو مدل‌ ارتقایافته از سوییچ‌های خود یکی از سری Director-cl آموزش CCSP فیلم های آموزشی CCSP آموزش پیکر بندی SWITCH فیلم های آموزش CCNP دوره CCNP آموزش سیسکو آموزش ASA VPN Options آموزش آموزش Implementing Clientless SSL VPNs آموزش آموزش Cisco AVVID Framework Essentialsآموزش آموزش کانفیگ سویچ سیسکو آموزش CCDA آموزش Enterprise Composite Network Model Essentialsآموزش آموزش قدم به قدم CCIE آموزش کامل CCIE در سیسکو آموزش CCNP Security VPN v2.0 642-648 آموزش آموزش CCVP آموزش CCIE آموزش تصویری CCIE آیا می دانید نحوه اتصال به یک سویچ سیسکو چگونه است؟ فیلم های آموزشی CCIE آموزش ccnp vpn درباره شرکت سیسکو آموزش تصویری CCSP